Identity Federation for AWS 2.12 Upgrade Notes

This page describes known issues as well as changes you should be aware of before deciding whether or not to upgrade to Identity Federation for AWS 2.12.

 

Consider testing of app upgrades before rollout into critical production environments

As always, best practices suggest to test each app upgrade in a staging environment before rolling it out to critical production environments.

Bamboo

Potential upgrade issue on remote agents

Bamboo might be unable to upgrade apps on running remote/elastic agents:

This long standing upstream issue had been resolved as of Bamboo 5.3. However, there seems to be a regression in Bamboo versions 5.6+, which expose a similar defect.

In case you are affected, this can usually be remedied by restarting the Bamboo server or disabling/reenabling the remote agent.

Please refer to our KB article Unable to execute task due to plugin not being installed for details.

Bitbucket

There are no known issues or changes requiring awareness for this upgrade.

Confluence

There are no known issues or changes requiring awareness for this upgrade.

Jira

There are no known issues or changes requiring awareness for this upgrade.